IBM Support

Data going to incorrect storage pool

Troubleshooting


Problem

File or directory data is stored in an unexpected or incorrect storage pool

Cause

The basic determining factor that dictates where the storage pool file and directory data will be stored is the management class they are bound to, via the storage pool destination defined in the copy group.

Situations can occur where data is being stored in a storage pool that is not the expected one. Sometimes directory data will be stored in a different storage pool than file data due to misunderstandings of the configuration parameters.

For instance, directory data is stored to a tape storage pool, while file data is stored to a disk storage pool. The most common reason for this to occur is that the directory data is being sent to the destination on the copy pool of the management class with the longest retention value set (retainonly). By default, directories are bound to the management class with the longest retention value, This behavior can be overridden by defining the DIRMC client option in the client dsm.opt file.

Diagnosing The Problem

This behavior can be diagnosed with the aid of the following data:

- Dsminfo.txt file from the affected client(s) - this is generated by issuing the Q Systeminfo command at a dsmc client command line. Note that the verbose option must be enabled so the schedule log will contain the necessary data.
- Actlog from the Tivoli Storage Manager server
- Query Copygroup f=d command output from the Tivoli Storage Manager server

The schedule log will show the following sequence, files are being sent, when a directory needs to be sent the initial sending of the object fails, a media wait occurs, then the directory is successfully resent.

04/25/2011 19:12:37 Normal File--> 120 \\sbes01pw\c$\WINDOWS\system32\config\netlogon.ftl [Sent]
04/25/2011 19:12:37 Directory--> 0 \\sbes01pw\c$\WINDOWS\system32\wbem\Logs ** Unsuccessful **
04/25/2011 19:12:37 ANS1114I Waiting for mount of offline media.
04/25/2011 19:12:40 Retry # 1 Directory--> 0 \\sbes01pw\c$\WINDOWS\system32\wbem\Logs [Sent]

This sequence will be observed each time a directory is stored to the Tivoli Storage Manager server.

The actlog will show a volume mount and open, then close, that correlates to the sending of the directory.

The policy domain information for the client can be obtained from the dsminfo.txt file, the Query Copygroup information can be used to determine the management class with the longest retention setting.

Resolving The Problem

Possible actions to resolve the situation are to explicitly set the management class that directories should be bound to with the DIRMC option, or to increase the retainonly value on the desired management class so it has the longest retention. The DIRMC option can be set in the dsm.opt file for the client(s), or specified in a client option set on the Tivoli Storage Manager server.

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Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21304552