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Data Collection Steps for SCP Stalled Issue

Troubleshooting


Problem

while transferring file from particular AIX server to the windows server using SCP connections get stalled

Cause

Due to the missing packets inbetween the servers

Environment

Diagnosing The Problem

Here is detailed data collection steps needed for the scp stalled issue.

on client LPAR sending side:
# pmtu display > /tmp/pmtudisplay.out
# entstat -d <sending Adapter > > /tmp/entstat2.before
# tcpdump -w /tmp/tcpdump.out -i <sending Interface>
# iperf -c <Traget IP> -t60 -P 8 -m > /tmp/iperfclient.out
# entstat -d <sending Adapter > > /tmp/entstat2.after
# kill -9 < Process ID > // Find PID of the tcpdump and kill it

on VIOS sending side:
# ifconfig <SEA interface> up // If there is no interface on SEA
# entstat -d <sending Adapter> /tmp/entstat2.before
# tcpdump -w /tmp/tcpdump.out -i <Sending Interface>
# entstat -d <sending Adapter > > /tmp/entstat2.after
# kill -9 < Process ID > // Find PID of the tcpdump and kill it

on windows machine:
start an sniffer/port mirror with equivalent flags as AIX.

on the VIOS receiving side: zurviocdc029
# ifconfig <SEA Interface> up // If there is no interface on SEA
# entstat -d <Receiving Adapter> > /tmp/entstat.before
# tcpdump -w /tmp/tcpdump.out -i <Receiving Interface>
# iperf -s -P 8 -m > /tmp/iperfserver.out
# entstat -d <Receiving Adapter> > /tmp/entstat28.after
# kill -9 < Process ID > // Find PID of the tcpdump and kill it

Tar the files and upload for review.

[{"Product":{"code":"SWG10","label":"AIX"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"}],"Version":"Not Applicable","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}}]

Document Information

Modified date:
17 June 2018

UID

isg3T1026605