IBM Support

DASH Import Function Failing with Error CTGWA2057E

Troubleshooting


Problem

Attempts to perform Dashboard Application Services Hub (DASH) utility "consolecli.sh Import" generates error messages and the import fails.

Symptom

The following message appears on the command line:
SEVERE: CTGWA2057E Plug-in "ImportPagePlugin" failed during migration, performing roll back.
CTGWA7091I Performing rollback.
SEVERE: com.ibm.tivoli.nc.migration.plugin.MigrationPluginException:
CTGWA7088E Error verifying username/password, responsecode: 0.
SEVERE: CTGWA2060E Plug-in "ImportPagePlugin" failed during restore.
SEVERE: CTGWA2190E Plug-in roll back failed. List of failing roll back
plug-ins written to file /sys_apps_01/IBM/dash/JazzSM/ui/plugins/failed_rollback.import.
Check logfile /sys_apps_01/IBM/dash/JazzSM/ui/logs/consolecli.log for more messages.

Cause

Customer reported they updated their SSL certificates recently. However, upon further discussion it was revealed they updated their individual User Certificates, not the Signer Certificates.

Diagnosing The Problem

Looking in the consolecli.log shows the following error:
[Timestamp] com.ibm.tivoli.nc.migration.MigrationController migrate
WARNING: Plug-in 'ImportPagePlugin' failed during migration, performing rollback.
Throwable occurred: com.ibm.tivoli.nc.migration.plugin.MigrationPluginException: com.ibm.tivoli.nc.migration.plugin.MigrationPluginException: CTGWA7088E Error verifying username/password, responsecode: 0.

Resolving The Problem

Steps to take:
  1. Log in to the Websphere Administrative Console.
  2. Expand Security and click SSL certificate and key management. Under
  3. Configuration settings, click Manage endpoint security configurations.
  4. Select the appropriate outbound configuration to get to the (cell):TIPCell: (node): TIPNode management scope.
  5. Under Related Items, click Keystores and certificates and click the NodeDefaultTrustStore keystore.
  6. Under Additional Properties, click Signer certificates and Retrieve From Port.
  7. In the Host field enter localhost in the host name field, enter 16311 in the Port field, and localhost_cert in the Alias field.
  8. Click Retrieve Signer Information.
  9. Verify that the certificate information is for a certificate that you can trust.
  10. Click Apply and Save.
  11. Copy the trust.p12 from: 
    [JazzSM Home]/profile/config/cells/JazzSMNode01Cell/nodes/JazzSMNodes01/
    to 
    [JazzSM Home]/profile/etc

Now the import should run successfully.

[{"Product":{"code":"SSRLR8","label":"Tivoli Components"},"Business Unit":{"code":"BU053","label":"Cloud \u0026 Data Platform"},"Component":"Jazz for Service Management","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.1.1","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
13 April 2022

UID

swg21692507