IBM Support

CWWIM4513E The password match failed for the 'Admin' principal name

Question & Answer


Question

After upgrading to BAW, I am unable to run the "createObjectStoreForContent command". I see the following error:
CWTDS0001E: The object definition 'The user is not authenticated. Message was: CWWIM4513E  The password match failed for the 'Admin' principal name. Root cause:com.ibm.websphere.wim.exception.PasswordCheckFailedException: CWWIM4513E  The password match failed for the 'Admin' principal name.' cannot be created. Details: '{1}'
OR:
After changing the deadmin password (BPM 8.6.0CF2018.03 or BAW:18.0.0.1) you see the above exception.
How do I resolve this?

Cause

First it is important to check if the password has been changed recently. From similar issues, we find that the password was changed in versions of BPM/BAW in which a known issue occurs that does not persist the change to the bootstrap user (usually default is the deadmin) in FileNet (BPM's Document Store).
How do you know if you are affected?
CPE 5.5.0 is part of the embedded Document Store for the following versions:
BPM 8.6.0CF2018.03
BAW:18.0.0.1
If you have changed the passwords and/or are upgrading from these versions, it is likely you would have seen these errors in the logs prior to the upgrade as well. Functionality in the product is not affected by these errors but do consistently persist in the SystemOut.logs. You should still be able to work with the Document Store.
The issue has been resolved in BAW 18002 and newer versions since the Document Store uses CPE 5.5.2 and higher. However, steps below are needed.

Answer

As noted in the technote above, reverting the password or upgrading are the only solutions available. These are the steps for both:

A) It is advised to revert the password back for the DeAdmin role to the original password via:
    1) Change the password back in the Manage Users section in the WebSphere Admin Console
    2) Sync the DeAdmin alias via the updateBPMAliasesAndRunAsRolesPasswords command
         Changing IBM Business Automation Workflow passwords
B) If you do not know the password and are still moving forward with the upgrade, this what you will want to do:
  1) Continue the upgrade and skip the Optional step (step 25) to install Case Management:
      Upgrading profiles from IBM Business Process Manager V8.6.x to IBM Business Automation Workflow V19.0.0.2
  2) Enable the ACCE console. If you are using the command line, please use "registeracceplugin.xml"
       Using the IBM Administration Console for Content Platform Engine
 
  3) In ACCE, go to the following
       Properties->System User Password, and update the password
       *The change does not require a restart.
    
  4) Run the "storePasswords" command. Remove the passwords from the "registertargetenv.xml" file prior to running the command:
      storePasswords command
 
  5) You should now be able to run the "createObjectStoreForContent command" successfully.
C) If you CANNOT upgrade or revert, you can temporarily turn off the wim class logging. Eventually, you will need to perform A or B above.
Turn the wim logging off in the WebSphere Admin Console.
*=info: com.ibm.websphere.wim.*=off

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Product Synonym

BPM,BAW

Document Information

Modified date:
14 September 2022

UID

ibm11074436