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A CWSCA2010W message is seen for WebSphere Process Server (WPS) when SCA thread hangs on a two-way asynchronous invocation

Troubleshooting


Problem

In the following scenario, a Service Component Architecture (SCA) thread hangs during a two-way asynchronous operation: [

  • A Business Process Execution Language (BPEL) process or mediation flow component (MFC) asynchronously starts a two-way operation on an SCA binding.
  • The SCA binding defines an interface with a two-way operation (request and response message).
  • The BPEL process or mediation flow reference is assigned the quality-of-service (QoS) parameter Asynchronous invocation with the value Commit.
  • Security and identity assertion are enabled on WebSphere Process Server or WebSphere Enterprise Service Bus, which is hosting the client (SCA import) and server application (which is started using an SCA export).
]

Symptom

When the asynchronous invocation of the two-way operation starts, the running SCA thread of the current transaction hangs. The target service is invoked, but the thread remains in a hung state. Eventually, the current transaction times out and causes a rollback.

Cause

With an asynchronous invocation that uses the deferred response invocation style with the Commit qualifier (two-way operation), the message might not be delivered to the target until the transaction commits. As a result, if no response from the target is received, the SCA internal invoke response call hangs and times out.

Environment

This problem can occur on a stand-alone server or application deployment cluster. It is more likely to occur on a Mediation Flow Component (MFC) than BPEL processes because a mediation flow thread blocks until the response message is retrieved.

Diagnosing The Problem

At run time, the following warning message is logged in the SystemOut.log file of the server with JR29600 installed:

[1/1/09 10:00:00:000 CEST] 00000099 Core W CWSCA2010W: SCA
Component "Mediation" has attempted to make an asynchronous invocation using the deferred response invocation style against reference
"SCAImportPartner". This reference has the qualifier 'deliverAsyncAt' = "Commit". This is a conflict that will cause the invocation to fail. Please change the 'deliverAsyncAt' qualifier on "SCAImportPartner" to "Call".

After the warning, and depending on the server configuration for hang detecting policy, the following message is logged on the same thread:

WSVR0605W: Thread 00000099 has been active for 600000 milliseconds  and may be hung.  There are 1 threads in total in the server that may be hung.

Resolving The Problem

Change the asynchronous invocation style (QoS) setting on the calling components reference to Call:




Using a one-way operation for asynchronous invocations allows you to use Commit as the asynchronous invocation and does not cause this problem.

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Product Synonym

WPS

Document Information

Modified date:
15 June 2018

UID

swg21393260