IBM Support

CS031 when trying to start a session with CL/SuperSession

Troubleshooting


Problem

Your request to start a session fails with message: CS031 The virtual session manager could not allocate resources.

Cause

There are no more virtual terminals available in the pool for the Application just selected.

Diagnosing The Problem

Each application session definition specifies (explicitly, or defaults to) a virtual terminal pool. A virtual terminal pool contains virtual terminals that can each support multiple concurrent sessions. When all of the terminals in a virtual terminal pool are used, the pool is full (exhausted) and can not support any more virtual sessions for a particular Application. A pool can be shared by multiple applications it may only be exhausted for one of those applications. Users selecting the other applications sharing that same Pool will not receive a CS031

The condition is recoverable.

Resolving The Problem

As users of that pool terminate sessions, virtual terminals become available for reuse. Additional terminals can be added dynamically using the VSM DEF command.

To avoid the condition, administrators should periodically review their virtual terminal definitions. The VSM LIST and VSM DISPLAY commands can be used to report virtual terminal activity.

The IBM CL/SuperSession HelpDesk also provides a facility for monitoring virtual terminal pools. The "Monitor" panel (Goto -> Switch to Monitor) displays data for six user-defined virtual terminal pools, sorted alphabetically. For each virtual terminal displayed, the panel shows:

  • the name of the virtual terminal pool
  • the number of virtual terminals in the pool
  • the number of sessions within the virtual terminal pool

For general information on virtual terminals, including estimating the number of concurrent sessions supported, refer to Chapter 5 of the "CL/SuperSession Basic Configuration Guide" in the section titled, "Virtual Terminal Pool Sizes."

For additional information on the VSM commands, refer to the "CL/SuperSession Operator's Guide."

For additional information on using the CL/SuperSession HelpDesk to monitor resources, refer to the document "Using the HelpDesk Facility."

[{"Product":{"code":"SSSN2Z","label":"IBM CL\/SuperSession for z\/OS"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Reliability","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"1.4.7","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Product Synonym

LS147

Document Information

Modified date:
03 August 2018

UID

swg21184907