IBM Support

Could not query NPS state! Cannot continue.

Question & Answer


Question

[] -------------------------------------SETUP------------------------------------- User will be prompted after prerequisites are checked. Now checking that cluster manager is stopped [DONE] Now checking that local host is active (primary) [DONE] Now checking user environment permissions [DONE] Now checking that NPS is stopped [FAIL] Could not query NPS state! Cannot continue. Now cleaning up [DONE] Now removing the lock file [DONE] ------------------------------------SUMMARY------------------------------------ Final Status [FAIL] Total Failures 1 []

Cause


[nz@%%%%%%-node1 ~]$ nzstate
Error: unable to connect to %%%%%%' - No route to host.
Unable to route to host, even if changing in
"export NZ_HOST=%%%%%%%" to NZ_HOST=%%%%%%%-node1, this will not correct the issue

Answer

Execute the following command. Keep in mind this will require bringing them system back online:

cibadmin -Q | grep wall



Check the output:

<primitive class="ocf" id="wall_ip" provider="heartbeat" type="IPaddr">
<instance_attributes id="wall_ip_ext_config">
<nvpair id="wall_ip_ext_attr_1" name="ip" value="12.34.5.67"/>
<nvpair id="wall_ip_ext_attr_2" name="netmask" value="23"/>
<nvpair id="wall_ip_ext_attr_3" name="nic" value="eth6"/>


From ifconfig find the Mask address for eth6: Mask:255.255.254.0

Then run:ifconfig eth6:0 12.34.5.67 netmask 255.255.254.0 up

This will bring up the ip address to run the rest of the upgrade.

[{"Product":{"code":"SSULQD","label":"IBM PureData System"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"System Upgrade","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.0.0","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
17 October 2019

UID

swg21903102