IBM Support

CORE_DUMP Error in VIOS Error Log and Data Collection

Troubleshooting


Problem

CORE_DUMP entry in PowerVM Virtual I/O Server (VIOS) error log (errlog) and data needed for diagnosis.

Symptom

CORE_DUMP entry in VIOS errlog

Cause

The error is logged when a program is terminated abnormally.  A core file can be created when various errors occur. Errors such as memory-address violations, illegal instructions, bus errors, and user-generated quit signals commonly cause a core dump. The core file that is created contains a memory image of the terminated process. Therefore, it is important to begin by determining which application generated the core dump.

Environment

Virtual I/O Server 3.1

Diagnosing The Problem

Identify the program name that generated the core dump by viewing the error report details using errlog command.  As padmin, run:
$ errlog -ls|more
LABEL:           CORE_DUMP
IDENTIFIER:      A924A5FC
Date/Time:       Thu Sep 1 15:10:08 2014
...snip...         
CORE FILE NAME
//core
PROGRAM NAME
cimserver
...snip...
ADDITIONAL INFORMATION
??
exit 174
__start B4
...
 
The error details provide important information including the PROGRAM NAME that generated the core dump, the location of the core file (CORE FILE NAME), and the call stack under the ADDITIONAL INFORMATION section. 

For this example, cimserver generated the core file name core in / (root) filesystem.

Resolving The Problem

What to do when the program name is not specific to the VIOS product itself
There are selected applications that are IBM approved to run on VIOS.  See VIOS Recognized List for details.  IBM VIOS support teams do not support these applications. For problems with these applications contact the vendor directly.

If the program name is a padmin command

Gather the following data and contact your local IBM Support Representative for investigation.

1. Collect snap from VIOS.

2. Collect snapcore data. As padmin, run:

$ oem_setup_env
# snapcore <full_path_to_core_file_name> <full_path_to_program_name>

where <full_path_to_core_file_name> is typically in the error details and <full_path_to_program_name> can be determined by using find or whereis command, i.e.

# find / -name cimservera -print
/opt/freeware/cimom/pegasus/bin/cimservera
find: 0652-023 Cannot open file /proc/8585222.

# whereis cimserver
cimserver: /usr/bin/cimserver

The snapcore command creates *.pax file in /tmp/snapcore directory.
# cd /tmp/snapcore
# ls -la            >Look for the snapcore file name

To redirect snapcore data to a different directory, use -d flag, e.g.

# snapcore -d /<path_to_dir_where_data_will_be_packed> <full_path_to_core_file_name> <full_path_to_program_name>

Rename the file to reflect your Support Case # using the following naming convention:
# mv <snapcore_file_name> TS<xxxxxxxxx>.<snapcore_file_name>

Send in the snapcore file in the same manner you uploaded the VIOS snap.

Related Information

[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSPHKW","label":"PowerVM Virtual I\/O Server"},"ARM Category":[{"code":"a8m50000000L0LLAA0","label":"PowerVM VIOS-\u003EERROR LOG"}],"ARM Case Number":"TS008313653","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
19 July 2023

UID

isg3T1024206