Troubleshooting
Problem
Customer installs Controller on a Windows 2019 Server.
- IMPORTANT: Windows 2019 is not officially supported for Controller 10.3.1/10.4.0. See link at end of this Technote for more details.
I.T. administrator starts the relevant Controller Web windows services:
- IBM Cognos Controller Web
- IBM Cognos Controller Web UI
Initially the service seems to work OK. However, after approximately 1 minute, the IBM Cognos Controller Web windows service shuts down.
Symptom
The IBM Cognos Controller Web windows service stops approximately 1 minute after starting.
More Details:
After starting the IBM Cognos Controller Web windows service:
- The following process is executed: prunsrv.exe
- This causes the following process to start: Javaw.exe
After about one minute:
- the prunsrv.exe process closes
- This leaves just the Javaw.exe open/running.
This will cause the IBM Cognos Controller Web to look like it is not started.
- However, Controller Web itself still works (because it is contained within the Javaw.exe process).
For the record, if everything is working correctly (normally) then it should look like this:
This shows 2 prunsrv.exe processes opened/running:
- One for fcmweb
- another for frontend and the javaw.exe
Cause
Limitation of the Websphere components (bundled with Controller), triggered by a change in the behaviour how Windows 2019 treats its 'Start' command.
- TIP: For more details on this Windows change, see third-party link at the end of this Technote.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
For the avoidance of doubt, Windows 2019 is not officially supported for Controller 10.3.1/10.4.0.
- See link at end of this Technote for more details.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Environment
This behaviour has been seen in the following environments:
- Controller 10.3.1 & 10.4.0
- Windows Server 2019 & Windows 10.
Diagnosing The Problem
After starting the Controller Web Windows service (fcmweb), check if it remains opened
- If it shuts down, check if the prunsrv.exe process is closed, but the Javaw.exe is still running
Resolving The Problem
Fix:
Windows 2019 is not officially supported for Controller 10.3.1/10.4.0.
- See link at end of this Technote for more details.
Workarounds:
There are two methods to workaround the problem:
Method #1
Ignore the problem.
Controller Web will still work (even with the prunsrv.exe closing as the Java process remains opened)
- Therefore you can still use it
The only downside is that the Windows service will appear as stopped/closed
- Therefore if you ever want to restart it (in the future) you will need to manually kill the javaw process.
Method #2
Make a temporary change to the following file: install_service.bat
- TIP: By default, this is located here: c:\Program Files\ibm\cognos\ccr_64\fcmweb\
IMPORTANT: ** This change will be reverted every time an update is applied to Controller **
=> Therefore you will need to repeat the change each time you upgrade/patch the server.
Steps:
1. Browse to here: c:\Program Files\ibm\cognos\ccr_64\fcmweb\
2. As a precaution, create a backup of: install_service.bat
3. Edit the following file (for example with notepad): install_service.bat
4. Search for: StartParams=start#%WLP_SERVER_NAME%
5. Modify the change it to: StartParams=run#%WLP_SERVER_NAME%
6. Save the file
7. Make sure that:
- The 'IBM Cognos Controller Web' Windows service is stopped
- The Javaw process has been ended/closed (in Task Manager)
8. Double-click on the file: uninstall_service.bat
9. Double-click on the file: install_service.bat
10. Open Windows Services, to check to see that the 'IBM Cognos Controller Web' service has been created
11. Start the service 'IBM Cognos Controller Web'
- Notice how it now remains as running forever
- NOTE: instead of the Javaw.exe, there will be a Java.exe process!
Related Information
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.3.1, 10.4.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
17 May 2019
UID
ibm10884802