IBM Support

Controller web "Internal server Error" when click on company/submission, caused by account reconciliation configuration

Troubleshooting


Problem

User launches Controller Web. User clicks on 'Company/Submission'. - An error appears. A similar error occurs if the user tries to open a 'project'.

Symptom


Internal Server Error
... STATUS 500 ...
...StorageException.ID ... NO_SUCH_ENTITY

Cause

There are several possible causes for similar errors.

  • TIP: See separate IBM Technote #2002887 for more examples.

This Technote specifically relates to the scenario where the cause is a limitation of Controller Web version 10.3, when the 'Reconciliation Setting' is set to 'Journal Type':

TIP: The above settings are configured inside the main Controller client, inside "Maintain - Configuration - General", in the "Reconcile 1" tab.

More Information:
Controller Web has the following limitations:
  • The reconciliation settings must be configured to be done by "Closing version" (not by "Journal type").
  • Reconciliation will always be done for the closing version selected in general configuration, but the differences can be broken down by journal type.
  • Reconciliation and status setting will be done by "Total Difference" or "Difference per Row", depending on the settings in general configuration.
  • "Largest difference accepted" applies to Between Accounts and Opening Balances (Debit/ Credit must always be zero).
  • "Set status for submission to Ready after reconciliation" (general configuration, tab Reconcile 1) is not supported. You must actively submit your company to get status Ready

===============================================
NOTE:
  • The limitation where Controller web does not support "Journal Type" is currently (December 2017) not likely to be removed for some time. Customers are encouraged to use the Enhancement Request (ER) website to create a new ER (or add their name to an existing ER).
  • However, there is a defect (reference APAR PI80950) relating to the fact that the technical error message should not appear for end users. The defect fix relates to replacing the harsh technical error with a softer more-understandable error.
===============================================

Resolving The Problem

Ensure that all the settings of Controller are correctly configured, to obey the limitations described above.

Example:
In one real-life customer example, they were using the reconciliation type 'Journal Type'

  • The solution was to change it to "Closing Version".

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.3","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21998917