IBM Support

Controller FAP error 'Could not login to TM1' ... 'SystemServerNotFound' or 'SystemServerConnectionFailed'

Troubleshooting


Problem

User launches "IBM Cognos FAP" from the start menu. The Controller "Financial Analytics Publisher" (FAP) Window appears. User starts a publish. User clicks the 'logs' tab. After a few seconds, an error appears.

Symptom

During the Initial Publish, the following sequence of log messages is seen in the 'Log' tab of the FAP GUI (with the 'Update Automatically' box ticked):

  • New active source detected
  • Source operations failed unexpected
  • Could not login to TM1 host <hostname> server name <datamart name> user <user name>

Hovering the mouse over the "Could not login to TM1" error shows the additional error detail:

    SystemServerNotFound or 'SystemServerConnectionFailed'

Cause

There are many possible causes for the generic "Could not login to TM1 host" error.

  • TIP: See separate IBM Technote #1664572 for more examples.

This Technote specifically relates to the scenario where the additional error mentions 'SystemServerNotFound' or 'SystemServerConnectionFailed', and the cause is a connectivity issue between Controller/FAP server and the server hosting the TM1 Data Mart.

Resolving The Problem

Correct network communication between servers (the Controller/FAP server and the server hosting the TM1 Data Mart.).

Steps:

First, ensure that the firewall of the TM1 service's Host machine is not blocking communication:

  • Turn off all firewalls and restart the Initial Publish.

Next, investigate the connectivity of the TM1 server's Host by performing the following:

1. Ping the TM1 server host (inside a command prompt)
  • check that the connection is good.

2. Test the port that your TM1 Cube service is using by using Command Mode >
telnet TM1hostname.hostdomainname.com xxxxxxx where xxxxxx is the port number in tm1s.cfg
  • If the port is responding, the DOS cmd box will go blank, Close it with the top right 'x'.
  • If the port is not responding you will see dialogue such as: Connecting To TM1hostname.hostdomainname.com <long wait> ...Could not open connection to the host, on port xxxxxx: Connect failed

(if Telnet command is not available, go to Manage Computer > Add Features and add it - usually no need to reboot to activate Telnet)

If the Telnet port test appears to fail, very likely the firewall on the TM1 host machine is not accepting incoming connections on the needed port. Go to the firewall settings and add/extend the firewall rule to open this port. Then in the FAP GUI, try restarting the Data Mart as this may be the fix that was needed.

If above connectivity seems fine, at this point try rebooting the TM1 host machine. Once the TM1 services have all restarted go to the FAP host and in Services restart the FAP service. See if an Initial Publish works now or does the error stay the same?

3. Install TM1 Architect (this is the client side of TM1) on the same machine where the Controller/FAP ins installed.

4. Start Architect and browse for the expected TM1 cube service

  • Click "File > Options > Admin Host"
    Enter the same name as used in the ping (see step 2 above)
    Click "File - Refresh Available Servers".
  • If Architect does not show the server called <datamart name> under 'Server Explorer' TM1 tree then there is a basic connectivity issue between the Controller server and the TM1 service host machine.

Finally, see also Technote 1599573 Synchronisation Issue where the cause could be that the FAP service has gone out of synchronisation with the TM1 server.

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Document Information

Modified date:
15 June 2018

UID

swg21657213