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'Content Manager failed to start because it could not load driver "com.microsoft.sqlserver.jdbc.SQLServerDriver"' when starting IBM Cognos service

Troubleshooting


Problem

Administrator launches 'Cognos Configuration', and presses 'Start'. An error appears.

Symptom


[Content Manager database connection]
[ ERROR ] The database connection failed.
[ ERROR ] Content Manager failed to start because it could not load driver "com.microsoft.sqlserver.jdbc.SQLServerDriver".

Cause

Missing database connector (JDBC JAR file) inside the relevant Cognos Analytics (or Cognos BI) folder.

Resolving The Problem

Copy the relevant database connector file (for example 'sqljdbc4.jar' or 'mssql-jdbc-7.0.0.jre8.jar') into the relevant Cognos Analytics (or Cognos BI) folder.

Steps:
1. Download the relevant JAR file (for example 'mssql-jdbc-7.0.0.jre8.jar')
  • TIP: For details on what JAR file you need (and where to get it) see separate IBM Technote #301623.

2. Logon to the Cognos Analytics (CA) server, and browse to the relevant folder
For Controller 10.3.1 using the bundled version of Cognos Analytics (CA) 11.0.7, the default location is here:
C:\Program Files\ibm\cognos\analytics\drivers
 
  • NOTE: Some documentation mentions the folder 'C:\Program Files\ibm\cognos\analytics\webapps\p2pd\WEB-INF\lib' but this can cause issues in rare circumstances, for example see separate IBM Technote #295205.
 
3. Copy the JAR file into that folder
  • In some situations, it is necessary to now reboot the CA server
4. Test.

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Document Information

Modified date:
23 April 2020

UID

swg22011794