Troubleshooting
Problem
When adding a "Console Integration" in the Dashboard Application Service Hub, using the Test button fails with an error message: Unable to connect to the remote console.
Symptom
The following error is being displayed:
"Status: Unable to connect to the remote console. Please check the console URL externally to ensure it works."
When testing the URL used in the configuration, it works externally in a browser.
Cause
In this case, the SSL certificate was not retrieved after Impact server was reinstalled. This caused the connection failure.
Diagnosing The Problem
Check the SystemOut.log or trace log for SSL errors like these:
CWPKI0022E: SSL HANDSHAKE FAILURE: A signer with SubjectDN "CN=d<xxxx>, O=<xxxx>, OU=<xxxx>, C=<xx>" was sent from target host:port "<FQDN>:16311". The signer may need to be added to local trust store "/opt/ibm/netcool/jazzsm/profile/config/cells/JazzSMNode01Cell/nodes/JazzSMNode01/trust.p12"
Resolving The Problem
You can use the Retrieve from port option in the administrative console to retrieve the certificate and resolve the problem. If you determine that the request is trusted, complete the following steps:
- Log into the administrative console.
- Expand Security and click SSL certificate and key management. Under Configuration settings, click Manage endpoint security configurations.
- Select the appropriate outbound configuration to get to the (cell):JazzSMNode01Cell:(node):JazzSMNode01 management scope.
- Under Related Items, click Key stores and certificates and click the NodeDefaultTrustStore key store.
- Under Additional Properties, click Signer certificates and Retrieve From Port.
- In the Host field, enter the Fully Qualified Domain Name in the host name field, enter 16311 in the Port field, and <FQDN>_cert in the Alias field.
- Click Retrieve Signer Information.
- Verify that the certificate information is for a certificate that you can trust.
- Click Apply and Save
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Document Information
Modified date:
17 June 2018
UID
swg21959198