Troubleshooting
Problem
Connection failure when using the WebSphere® Transformation Extender Database Interface Designer to connect to Microsoft® SQL Server®.
Cause
Insufficient permissions for the Windows domain account.
Diagnosing The Problem
With the Database Interface Designer's (DID) trace feature enabled, double click on the Tables folder in the DID to generate a trace file. Review the trace file by clicking on the Toggle trace File menu bar icon looking for text similar to the following:
<9064-8652-07/11/13 09:02:49>: No existing connection was found.
<9064-8652-07/11/13 09:02:49>: Using Windows integrated security
<9064-8652-07/11/13 09:02:49>: **ERROR** Failed to create session
Resolving The Problem
If the user that has started the Database Interface Designer does not have access to the database server through Windows domain account security configuration, you cannot use the MS SQL Server driver in the Database Interface Designer.
Possible solutions are:
1) Use a local Microsoft SQL Server account in place of the Windows domain account.
or
2) Configure the Data Direct drivers that are provided with WebSphere Transformation Extender to use kerberos authentication. This would also require additional configuration on the SQL Server.
If the user does have appropriate permission, then configure the mdq file within the Database Interface Designer such that the user id and password entries are blank.
Product Synonym
Ascential Mercator DataStage TX
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Document Information
More support for:
IBM Transformation Extender
Software version:
8.4, 8.4.1, 8.3
Operating system(s):
Windows
Document number:
227369
Modified date:
16 June 2018
UID
swg21643638