IBM Support

Connecting to an outside service in Build Forge results in "Connection Refused"

Troubleshooting


Problem

Attempts to start IBM Rational Build Forge (BF) or experienced a loss of connectivity that is unable to re-establish results in the error "BuildForge_ServicesException(0): 111:".

Symptom

Unable to connect access the Management Console log-on screen.

Cause

The two most likely causes of a BuildForge_ServicesException(0) are:

  • Unable to connect to the database
  • The RBF-Services is missing and did not expand properly.

Diagnosing The Problem

Navigate to the Apache/Tomcat/logs/ and open the Catalina.log checking for errors that resemble the one indicated in this technote.

Resolving The Problem

Preferred method:

  • Reinstall
  • Restore from last known working config.

Note, If the rbf-services were removed by accident, it is possible additional files where removed as well. If possible, use the preferred method.

Alternate Method:

  1. Navigate to the IBM\RAFServer\rafw\framework\wizard
  2. Copy the original rbf-services used during the install into the Apache webroot directory
  3. Restart Rational Build Forge.

[{"Product":{"code":"SSWJ96","label":"Rational Automation Framework"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"General Information","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"3.0;3.0.0.1;3.0.0.2;3.0.0.3;3.0.0.4;3.0.0.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
09 October 2018

UID

swg21638896