Question & Answer
Question
Can the HMC be configured to manage the Power8 Firmware Entitlement key automatically?
Cause
Might be seeing reference code, A7004761, showing up in the service event log on the HMC for some managed systems. The reference code indicates that the server's update access key has expired.
Answer
Power8 introduced a new feature and requirement for updating system firmware. Installing firmware requires a check for firmware entitlement key which is called the Update Access Key (UAK). When performing a firmware update on Power8 the UAK is checked to see if the system is still under IBM Hardware Maintenance Contract and if it is the update is allowed. If the UAK has expired and the system is still under warranty by IBM then obtaining a new UAK will need to be performed before the firmware update can be completed. There is already technical information published in technical reference T1020902, Management of POWER8 Update Access Keys, that describes checking and updating the UAK manually.
To automate the process you will want to have the HMC setup as a call home server. Once you have that then you can also configure it to transmit UAK information to IBM and the feature will also allow for automatic updates. The minimum firmware level that supports automated pull of UAK is FW840 and this is the system firmware, not HMC. It best to be at the latest system firmware you can be, but its also best to be at HMC v8r860 with SP2 installed or higher if this is your first time to be checking and setting the configuration of your HMC for your Power8 systems.
The configuration task are found in the Enhanced UI under the Serviceability menu. Select the menu option called Service Management then select the task option called, "Transmit Service Information."
Once you have the Transmit Service Information task up, make sure the option box for Update Access Key Information is
checked. Use the OK button to save any changes.
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
isg3T1025621