Troubleshooting
Problem
A list of common reasons for application bind errors and recommended solutions.
Cause
Several problems can cause these errors:
- PORT statement conflict (EACCES). Common causes are:
- The port you are using is defined in PORTRANGE
- The started application name doesn't match the application name defined in the PORT statement
- The user ID associated with the application does not have access to the SAF resource specified on the PORTRANGE statement.
- Socket already bound to the port (EADDRINUSE). Common causes are:
- SO_REUSEADDR was not used
- The socket is bound to same port/IP address pair, without SHAREPORT (only TCP)
- IP address conflict (EADDRNOTAVAIL). Common causes are:
- IP address not valid (for example, a broadcast or nonexistent IP address)
- Various DVIPA failures (for example, JRDVIPACONFLICTIPADDR - DVIPA already active on another stack that will not release it.)
Resolving The Problem
Review the common causes and take appropriate action.
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Document Information
More support for:
z/OS Communications Server
Software version:
1.6, 1.7, 1.8, 1.9, 1.10, 1.11, 1.12, 1.13, 2.1, 2.2
Operating system(s):
z/OS
Document number:
76767
Modified date:
15 June 2018
UID
swg21173083