Question & Answer
Question
What data needs to be gathered for problem determination of Oracle Weblogic integration with IBM Security Access Manager issues ?
Cause
Data collection for debugging
Answer
Must ask questions:
1) Please confirm that you performed the integration as per the supported Oracle WebLogic Server
Integration Guide, am_weblogic_int_guide.pdf
2) What are the versions of the product components for TAM/ISAM and Oracle Weblogic in your env?
3) How do you construct your junction? What type of junctions have you configured?
4) What is the target application or end-point? Is any level of security
configured or enabled on the target application?
5) What and where are you seeing the error?
6) Is the problem re-producible? What are the steps you follow to re-produce it?
7) Can the Oracle Weblogic site be accessed without WebSEAL?
Mustgather details:
1) Provide a diagram to showcase an architectural view of the configured environment
2) The WebSEAL configuration .CONF files
3) Provide the command used to create the WebSEAL junctions
4) Provide screenshots to capture the authentication process to demonstrate how the SSO is failing
5) Provide screenshot of the error you are seeing
6)Confirm the location of the AMSecurityProviders.jar file is under
the following directory -
C:\Oracle\Middleware\wlserver_10.3\server\lib\mbeadntypes\
Please take a screen shot of the AMSecurityProvider.jar file within its current location.
7). Execute the following command against the AMSecurityProvider.jar file -
jar -tf AMSecurityProvider.jar > c:\temp\WLSClassDump.log
and validate that we can see the following file -
com/ibm/tivoli/integration/am/wls/sspi/authentication/AMIdentityAsserterLiteMBeanImpl.class
Please send this file to us so that we can also validate that the file exists.
8) Validate that the AMSecurityProvider.jar file has the correct levels
of permissions to be executed by the WebLogic server. This file should
be owned and have the same permissions as the other jar files within the
mbeanstypes directory.
9) ISAM MustGather http://www-01.ibm.com/support/docview.wss?uid=swg27013204
Product Synonym
ITAM TAM SAM ISAM
Was this topic helpful?
Document Information
More support for:
Tivoli Access Manager for e-business
Software version:
All versions
Document number:
520693
Modified date:
16 June 2018
UID
swg21691597