Troubleshooting
Problem
Using Cognos Configuration or from the local services screen, the Cognos service will not start. The Event log contains the following error... Faulting application name: cogbootstrapservice.exe, version: 10.2.6101.12, time stamp: 0x54ad5870 Faulting module name: ntdll.dll, version: 6.3.9600.18438, time stamp: 0x57ae642e Exception code: 0xc0000374 Fault offset: 0x00000000000f1b70 Faulting process id: 0x79c Faulting application start time: 0x01d37896980bbeba Faulting application path: D:\ibm\cognos\c10_64\bin64\cogbootstrapservice.exe Faulting module path: C:\Windows\SYSTEM32\ntdll.dll ...etc. The contents of the cbs_run_WebSphereLiberty.log file show multiple instances of this error... ERROR t[de8] PingChildProcess ping loop: process "wlp" is not active, so restarting it.
Cause
Recently, there was an issue with disk space. Once the disk space had been recovered, the Cognos service would not start.
Diagnosing The Problem
The contents of the cbs_run_WebSphereLiberty.log file showed that there was a problem with starting the wlp process
Resolving The Problem
Allow a new workarea directory to be created by renaming <cognos_install_location>\wlp\usr\servers\cognosserver\workarea
and then restart the Cognos service.
Due to the problems with disk space, it is possible that it caused the contents of this directory to become corrupted.
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg22011841