IBM Support

Cognos service does not starts up, CAM-CRP-0321 The GSKit function 'gsk_environment_init' failed with the error code '12' recorded in cbs_run_WebSphereLiberty.log and cogserver.log.

Troubleshooting


Problem

All attempts to start up a new Cognos installation fail. The following messages are logged in cogserver.log by BiBusTKServerMain service and other external process as well as in cbs_run_WebSphereLiberty.log: CAM error: -2113929065CAM-CRP-0321 The GSKit function 'gsk_environment_init' failed with the error code '12'.

Cause

Broken installation

Diagnosing The Problem

RawCap pcap trace shows that communication on various ports is successful.

Regenerating crypto keys doe snot resolve the problem.

Resolving The Problem

Reinstall Cognos

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21988056