IBM Support

CM-REQ-4313 An error occurred during an export operation.

Troubleshooting


Problem

Exporting the entire content store fails with error "CM-REQ-4313 An error occurred during an export operation", even though the consistency check was successful.

Symptom

Following error is observed in IBM Cognos Administration

CM-REQ-4313 An error occurred during an export operation.

Following error is observed in cogserver.log file

CM-SYS-5029 Content Manager failed to retrieve an object class from the content
store cache.

CM-SYS-5027 A Content Manager internal error occurred while querying the content store cache.
Cache::GetObjectIntProperty::/Cache::OBJECT_IDToPtr::/Cache.OBJECT_IDToP
tr::Error accessing a non-existent object id with a NULL name. ID=0x642e

Cause

Report Output Version were also included in the export options.

Resolving The Problem

It is recommended to exclude the report output versions from the export to reduce the size of the export.

However if including the report output version results in failure of export then,

Clear/Empty the temp directory of Cognos to resolve the issue.

Steps to clear the temp dir:

1. Stop the Cognos services

2. Clear the contents of the temp directory <install dir>/cognos/temp.

3. Start the Cognos services.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Connection","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1;10.1.1;10.2;10.2.1;10.2.1.1;10.2.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21509319