IBM Support

CloudManager with OpenStack: How to change the expired Database password.

Troubleshooting


Problem

The default database password configured at install may expire if not managed by the system Operator preventing users from using IBM Cloud Manager with OpenStack (ICM)

Cause

Password expired.

Keystone log will report:

TRACE keystone.common.wsgi
OperationalError: (OperationalError) ibm_db_dbi::OperationalError: [IBM]
[CLI Driver] SQL30082N  Security processing failed with reason "1"
("PASSWORD EXPIRED").  SQLSTATE=08001 SQLCODE=-30082 

Resolving The Problem

Change the password.


#db2 connect to SAMPLE user ceilodb2 using OLDPWD new NEWPWD confirm NEWPWD

where SAMPLE is your database
where OLDPWD is the old password (default password is ceilometer)
where NEWPD is your new password


Alternative Method

Although we have seen this work in the field, this may or may not work and is offered as an alternative method to try.

1) Determine if any Openstack user IDs are expired using command :

chage -l <user ID>

You should see something like below. The "password expires" field would show that it expires if the data falls before or on the current system date.



Refer to this URL to get listing of Openstack user IDs :

https://www.ibm.com/support/knowledgecenter/en/SST55W_4.3.0/liaca/licac_appliance_id_passwords.html

NOTE: Not all passwords will be present on a node. One way to see which user IDs exist is the list the /home directory since each user ID should have a subdirectory under /home

2) This is an example to make the user to not expire the password :

chage -I -1 -m 0 -M 99999 -E -1 <user>


3) Once changes are made to extend the password expiration date on the Openstack user IDs, try to restart the Openstack service that had the issue.

[{"Product":{"code":"SST55W","label":"IBM Cloud Manager with OpenStack"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF016","label":"Linux"}],"Version":"4.1;4.2;4.3","Edition":"Advanced;Enterprise;Standard","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
17 June 2018

UID

nas8N1020768