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The CLM startup scripts for WebSphere Liberty indicate the server is already started when it is not

Troubleshooting


Problem

Attempts to execute the WebSphere Liberty startup script results in a message indicating the server is already running.

Symptom

Attempts to execute the WebSphere Liberty startup script results in the following message:

Server clm is already running.

When attempting to shut down the server using the shutdown scripts, the following message is received:

Server clm is not running.

Cause

The problem is caused by lock files left behind in the Liberty workarea directory. These files should be removed when the server is shut down but may remain in place after an unplanned outage.

Diagnosing The Problem

Navigate to the directory where CLM is installed, and go to the /server/liberty/servers/clm/workarea and check for files called .sCommand or .sRunning.

Resolving The Problem

If these files are present, delete them and run the server.startup script again. If running on Windows Server with User Account Control (UAC) start the script by right-clicking and clicking "Run as Administrator".

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Product Synonym

Rational Collaborative Lifecycle Management Solution

Document Information

Modified date:
28 April 2021

UID

swg21982338