About cookies on this site Our websites require some cookies to function properly (required). In addition, other cookies may be used with your consent to analyze site usage, improve the user experience and for advertising. For more information, please review your options. By visiting our website, you agree to our processing of information as described in IBM’sprivacy statement. To provide a smooth navigation, your cookie preferences will be shared across the IBM web domains listed here.
Troubleshooting
Problem
Unable to uninstall with error: "The feature you are trying to use is on a network resource that is unavailable ... 'IBM Tivoli Storage Manager Client.msi'"
Symptom
Add/Remove programs will present the following error:
"The feature you are trying to use is on a network resource that is
unavailable. Click OK to try again, or enter an alternate path to a
folder containing the installation package 'IBM Tivoli Storage
Manager Client.msi' in the box below: <non-existent network path>"
Cause
The IBM Tivoli Storage Manager Client.msi package cannot be located to uninstall the client. This may occur if the location where it originally existed was removed or is no longer available.
Environment
Windows
Resolving The Problem
1. Determine the level of client that is installed. Click the "Click here for more info" link under Add/Remove Programs for the Tivoli Storage Manager client.
2. Download the client level installation package from IBM. As of this writing, most V5+ client releases are archived/stored on the following public FTP server under the "maintenance/" or "patches/" directories: ftp.software.ibm.com.
3. Run the client installer downloaded on the affected client system. This will re-extract the packages (by default) to "C:\TSM_Images\TSM_BA_Client\" ... including the previously missing "IBM Tivoli Storage Manager Client.msi" package.
4. Once the extract is done, the installer should ask to Modify/Repair/Remove the current installation. Select "Remove."
5. Once completed, verify in Add/Remove programs that the client has been removed.
6. Install the desired level of Tivoli Storage Manager client that you wish to upgrade to via normal procedures.
[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]
Product Synonym
ITSM ADSM TSM
Was this topic helpful?
Document Information
More support for:
Tivoli Storage Manager
Software version:
All Supported Versions
Operating system(s):
Windows
Document number:
529409
Modified date:
17 June 2018
UID
swg21959921