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Client hangs on Reference Code 2005 during Live Partition Mobility

Question & Answer


Question

Why does my Live Partition Mobility operation hang on reference code 2005 on the source system and C20025FF on the destination.?

Cause

There are a number of things, including environmental issues, that can lead a mobile partition to hang on reference code 2005 during Live Partition Mobility. Here are some most common items to check.

Answer

1. In some cases, reference code 2005 may be valid during an LPM operation indicating the migration is in progress. This reference code may be displayed as the current state of the mobile partition when it is performing the drmgr command. The code is displayed on the source server while the partition is waiting to suspend, and on the destination server until the drmgr processing has completed."
In this case, the code does not necessarily indicate a problem. It is rather expected and normal and should clear up once the mobile partition has been migrated.

The LPM process executes the drmgr script in background. This command runs in background when a wait time is specified in the migration wizard. Setting the wait time to a value starts the execution of the drmgr command in the background that automatically starts a script that is run during LPM. A lower value can be specified for the wait time in the migration wizard based on the duration of previous migrations.

To determine if the code is normal, check the LPM wizard to see if the time the LPM operation has been running for is much longer than the wait time. If it is not, then wait for the "wait time" value to be reached.


On the other hand, if the reference code has been displayed after the "wait time" value has been reached, then it is possible there may be something else triggering the LED hang. In such case, see other common causes below.

2. Ensure source and target VIO servers are running at a supported VIOS level. Once a VIOS fixpack has been released, the VIO servers should not be running at a base level, such as 4.1.0.0).

3. Ensure VIO Server resources (memory and CPU) on source and target are optimal.
VIOS 3.1 and higher require a minimum of 4GB of memory and 1.0 CPU (entitle capacity). Ultimately, determining the amount of resources needed for a VIOS will depend upon its workload, and therefore, this values may vary.
To evaluate resources of a VIOS, please, run the VIOS Performance Advisor at the time the VIOS workload is at its peek and increase resources to the recommended values, before re-attempting LPM.

4. Missing paths or issues accessing the paths are also known to cause the reference code 2005.
If the mobile partition uses NPIV SAN disks, check the client's error log for storage issues, and if there are any, please, contact your storage support to address those errors before re-attempting LPM.

# errpt|more

5. Check for full file system (df -g) in rootvg for the client and VIO Servers.

6. Check for multiple default gateways

7.  Work with your SAN administrator to verify the storage LUN masking is properly configured for the secondary/inactive WWPN.  
8. Assess the physical layer.  Bad cabling is known to cause this type of LPM hang. 
9. Known Issues

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Document Information

Modified date:
03 March 2025

UID

isg3T1019286