Troubleshooting
Problem
A Tivoli Storage Manager client fails to start and Windows operating system issues an error message "The procedure entry point
Symptom
In this example when Tivoli Storage Manager Backup/Archive (BA) client is started, Windows reports that a procedure entry point for GetTickCount64 could not be located in the dynamic link library KERNEL32.dll:

Cause
This is usually caused by incomplete or broken upgrade of the Tivoli Storage Manager client, resulting in incompatible versions of the dynamic link libraries and executable binaries.
Diagnosing The Problem
- Download Process Monitor (see URL section for download link).
- Set filter to capture only events created by dsmc.exe
Menu -> Filter -> Filter...
- In dialog select "Process Name" , "is" and enter process name, for example "dsmc.exe", leave default action "Include", click "Add" and close dialog with "OK".
- Start dsmc.exe and after error is thrown, save Process Monitor log to a file in native PML format with all default options.
- Download Dependency Walker (see URL section for download link) run it, navigate to File / Open and select an executable file, for example C:\Program Files\tivoli\TSM\baclient\dsmc.exe.
- After program loads all dependencies, save the results as "Text with Import/Export List" and native "Dependency Walker Image".
Resolving The Problem
The incompatible dynamic link library needs to be replaced with an original one. To identify the incompatible library, collect the Process Monitor log and Dependency Walker result and send to IBM support:
Related Information
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Document Information
Modified date:
17 June 2018
UID
swg21680534