Troubleshooting
Problem
A Tivoli Storage Manager Backup-Archive client on Windows runs an incremental backup and fails with return code 653.
Symptom
The following errors are logged in the dsmerror.log of the client :
<timestamp> ANS0361I DIAG: ntfileio.cpp (3422): fioGetAttrib(\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopyNN\path\to\file) failed.
<timestamp> ANS1228E Sending of object '\\computer\f$\path\to\file1' failed
<timestamp> ANS4005E Error processing '\\computer\f$\path\to\file2': file not found
<timestamp> Return code 653 unknown
<timestamp> Unknown system error
Please check the TSM Error Log for any additional information
In this example, it shows the failure occurs when backing drive F:
Cause
Microsoft VSS errors
Diagnosing The Problem
Capture a client service trace. Examine the trace for errors. For example :
10/11/2014 01:26:45.496 [006196] [6692] : ntrc.cpp ( 724):
TransWin32RC(): Translated Win32 RC 2 (0x00000002) ...
...
10/11/2014 01:26:45.558 [006196] [6692] : ntrc.cpp ( 724):
TransWin32RC(): Translated Win32 RC 55 (0x00000037) ...
The first file operation failed with Microsoft error : Win32 RC 2
The second file operation failed with Microsoft error : Win32 RC 55
These Windows error codes are described as follows :
- Windows error code 2
ERROR_FILE_NOT_FOUND
2 (0x2)
The system cannot find the file specified.
- Windows error code 55
ERROR_DEV_NOT_EXIST
55 (0x37)
The specified network resource or device is no longer available.
Examine the Windows system event log for VSS errors. In this example, the following error is logged :
Source: VolSnap
Event ID: 25
Description:
The shadow copies of volume F: were deleted because the shadow copy storage could not grow in time. Consider reducing the IO load on the system or choose a shadow copy storage volume that is not being shadow copied.
The above text shows a VSS problem with the drive being backed up.
Resolving The Problem
In this example, the "SNAPSHOTPROVIDERFS VSS" client option is used. This indicates that Microsoft VSS snapshots are used to back up the volume. These errors indicate that the Microsoft VSS snapshot of the volume is reporting errors. In this example, the backup fails because of Microsoft event id 25. Refer to the following Microsoft article to resolve the VSS error :
http://technet.microsoft.com/en-us/library/cc734469(WS.10).aspx
Otherwise, you may want to stop using "snapshotproviderfs vss" to backup this F: drive. You would use one the following options :
include.fs F: snapshotproviderfs=none
--or--
snapshotproviderfs none
Ensure that you have all Microsoft VSS patches applied and contact Microsoft support for further help in resolving the VSS errors.
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Document Information
More support for:
Tivoli Storage Manager
Software version:
All Supported Versions
Operating system(s):
Windows
Document number:
254485
Modified date:
17 June 2018
UID
swg21687770