IBM Support

CLI - SSL certificate expiry issue

Troubleshooting


Problem

An error occurs when you run one of the following commands:
On Linux:
$ bin/pure -h <host system> -u <user> -p <password>
On Windows:
C:\> bin\pure.bat -h <host system> -u <user> -p <password>
The error displays the following message:
"CWZCI0010E: An error occurred with the SSL handshake with "127.0.0.1". You may use the -a or --acceptcert option to trust this certificate."

Symptom

The command fails.

Cause

Due to this certificate expiry issue, the following flash note is published:

Environment

All versions.

Resolving The Problem

The system that is accessed by the command-line interface uses self-signed certificates.

Run the -a or the --acceptcert option as follows to avoid an SSL handshake error:
On Linux:
$ bin/pure -h <host system> -u <user> -p <password> -a
On Windows:
C:\> bin\pure.bat -h <host system> -u <user> -p <password> -a

Document Location

Worldwide

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSM8NY","label":"PureApplication System"},"Component":"","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"All versions","Edition":"All editions","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
01 May 2019

UID

ibm10882046