Troubleshooting
Problem
Using EmailPlus and EmailRelay setup in PostOffice or SMTP Relay mode, email generated by ClearQuest may fail to be sent due to the email exceeding the predefined limit set by ClearQuest OSLC of 2000 characters.
Symptom
Emails are not received by the intended recipient.
Cause
Out-of-the box, IBM Rational ClearQuest OSLC REST API imposes a limit of how many characters will be read from a multi-line field of a ClearQuest record. The default value for this limit is 2000 characters. If an email Payload, generated by EmailPlus template rule ends up exceeding this 2000 character limit, the Payload is truncated by OSLC REST API. Since this Payload consists of XML data, the Payload becomes invalid after the truncation and thus EmailRelay fails to process the Payload and it cannot send the email to the intended recipient.
Diagnosing The Problem
Examine your CM Server's SystemOut.log file and if you see an error of the form:
[8/5/13 9:33:58:221 CDT] 00000018 OslcDbReader E An exception occurred while creating the emails_.
[8/5/13 9:33:58:221 CDT] 00000018 OslcDbReader E XML document structures must start and end within the same entity.
org.xml.sax.SAXParseException: XML document structures must start and end within the same entity.
then, it is most likely that you have run into this issue.
Resolving The Problem
There are two ways to address this issue. For best results, apply both technotes:
- Follow the instructions per technote http://www-01.ibm.com/support/docview.wss?uid=swg21590934 to increase the limit on multi-line field value from the default of 2000 to a larger number such as 10000.
- Follow the instructions per technote http://www-01.ibm.com/support/docview.wss?uid=swg21650960 to modify your EmailPlus template rules code to limit the size of your Payload email body.
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Document Information
Modified date:
16 June 2018
UID
swg21650979