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ClearCase Explorer crashes at startup after changing the registry server host in the ClearCase Control Panel in ClearCase 7.0.1.3

Troubleshooting


Problem

This technote identifies a defect that can occur in IBM Rational ClearCase (CC) version 7.0.1.3 where ClearCase Explorer crashes at startup after the registry server host was changed in the ClearCase Control Panel.

Symptom

After modifying the ClearCase Control Panel to point to a different registry server a subsequent attempt to bring up ClearCase Explorer crashes.



Note: This issue did not occur prior to ClearCase version 7.0.1.3.

Cause


This issue has been identified as a product defect under APAR PK79449.

Resolving The Problem

The defect has been resolved in ClearCase 7.0.1.5 and 7.1.0.2


WORKAROUND


Note: The following directions require you to edit the registry using the Windows Registry Editor. However, editing the Windows Registry incorrectly can cause serious problems that may require you to reinstall your operating system. Use Registry Editor at your own risk. Before proceeding review the Microsoft article, 256986 - Description of the Microsoft Windows Registry.

These steps will workaround this issue:

  1. Close ClearCase Explorer

  2. Change the registry server host identified in the Use registry server on host field of the ClearCase Control Panel:

  3. Remove the following Windows registry key:

    HKEY_CURRENT_USER\Software\Atria\ClearCase\CurrentVersion\ClearCaseExplorer

  4. Start up ClearCase Explorer

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"GUI: ClearCase Explorer","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0.1.3","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21368187