IBM Support

Changing the Character set of an Oracle Client

Question & Answer


Question

Why am I being prompted with a dialog box stating the text in requirement has been modified when opening, saving, or, closing a document in IBM® Rational® RequisitePro®?

Cause

One possible reason for this issue is that the character set being used on the RequisitePro client system is different than the character set on the Oracle database server.

Answer

Note:
This solution contains information about modifying the system registry. Before making any modifications to the Microsoft® Registry Editor, it is strongly recommended that you make a backup of the existing registry. For more information describing how to back up the registry, refer to the Microsoft Knowledge Base article http://support.microsoft.com/kb/256986.

  1. Run regedit, Registry window will appears
  2. Select HKEY_LOCAL_MACHINE
  3. Select SOFTWARE
  4. Select ORACLE
  5. Select NLS_LANG
  6. Modify to put in the following: AMERICAN_AMERICA.US7ASCII

The character set US7ASCII is the default subset for a Oracle Server. Verify this is the case or use the subset that is being used on the server.
[{"Product":{"code":"SSSHCT","label":"Rational RequisitePro"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Database: Oracle","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2002.05.00;2002.05.20;2003.06.00;2003.06.01;2003.06.10;2003.06.12;2003.06.13;2003.06.14;2003.06.15;2003.06.16;7.0;7.0.0.1;7.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

More support for:
Rational RequisitePro

Software version:
2002.05.00, 2002.05.20, 2003.06.00, 2003.06.01, 2003.06.10, 2003.06.12, 2003.06.13, 2003.06.14, 2003.06.15, 2003.06.16, 7.0, 7.0.0.1, 7.0.1

Operating system(s):
Windows

Document number:
356465

Modified date:
16 June 2018

UID

swg21281573

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