Question & Answer
Question
How do you change the administrative password in IBM SmartCloud Orchestrator Version 2.3?
Cause
Due to company policies, you might need to periodically change the password for the administrative user.
Answer
The administrative user is used across the following IBM SmartCloud Orchestrator components: IBM SmartCloud Orchestrator user interface, IaaS Gateway, and OpenStack. To change the password, complete the following steps:
- Change the password in the IBM SmartCloud Orchestrator user interface by editing the administrative user in the Users panel. Click Administration > Users.
Note: After you change the password, you cannot continue to work with the user interface until you complete step 6 of this procedure.
- Close your browser.
- Log onto the Region Server and encrypt the new password using the /usr/bin/openstack-obfuscate <new password> command.
- Log onto Central Server 2 and edit the /etc/iaasgateway/iaasgateway.conf file by changing the following line to the new password: password = <new admin encrypted password>
- Restart the IaaS gateway service by completing one of the following actions:
- If you are not using the IBM SmartCloud Orchestrator high availability solution, run the following command:
service openstack-iaasgateway restart - If you are using the IBM SmartCloud Orchestrator high availability solution, log into the System Automation Application Manager user interface and initiate a restart of the openstack-iaasgateway resource.
- Log on to Central Server 3 and restart the Workload Deployer service by completing one of the following actions:
- If you are not using the IBM SmartCloud Orchestrator high availability solution, run the following command:
service iwd restart - If you are using the IBM SmartCloud Orchestrator high availability solution, log into the System Automation Application Manager user interface and initiate a restart of the IBM Workload Deployer resource.
- Log on to Central Server 2 and restart the Virtual Image Library by completing one of the following actions:
- If you are not using the IBM SmartCloud Orchestrator high availability solution, run the following command:
service vil restart - If you are using the IBM SmartCloud Orchestrator high availability solution, log in to the System Automation Application Manager user interface and initiate a restart of the Virtual Image Library resource group.
- Log onto the Virtual Image Library user interface and select the OpenStack domain in the Operational Repositories section in the resource tree.
- Click Actions > Change Credentials.
- Specify the new password for the administrative user.
- Log onto Central Server 2, open the /root/keystonerc file, and change the export OS_PASSWORD=<old admin password> line to export OS_PASSWORD=<new admin password>
- If you are using a VMware or Power region, complete the following steps:
- Change the administrative password in SmartCloud Entry using the following command , which you need to run from the Region Server:
curl -v -ku admin:<old admin password> http://<ip address of the region server>:7080/cloud/api/users/admin -H "Content-Type:application/json" -d '{"username":"admin"," password":"<new admin password>","oldPassword":"<old admin password>"}' -X PUT - Restart the SmartCloud Entry service using one of the following actions:
- If you are not using the IBM SmartCloud Orchestrator high availability solution, run the following command:
service sce restart - If you are using the IBM SmartCloud Orchestrator high availability solution, log in to the System Automation Application Manager user interface and initiate a restart of the SmartCloud Entry resource.
- On the Region Server, update the /etc/nova/smartcloud.conf file by replacing the old encrypted administrative password with the new administrative encrypted password in the sce_connection_password property and in the admin_password property.
- Restart the openstack-smartcloud service by completing one of the following actions:
- If you are not using the IBM SmartCloud Orchestrator high availability solution, run the following command:
service openstack-smartcloud restart - If you are using the IBM SmartCloud Orchestrator high availability solution, log in to the System Automation Application Manager user interface and initiate a restart of the openstack-smartcloud resource.
- If you used admin as the user to connect to the cloud provider in the Image Construction and Composition Tool, complete the following steps:
- Remove the cloud provider from Administer > Manage Cloud Providers.
- Create the provider again and specify the new password.
- Re-import your images.
Note: If you stopped the Image Construction and Composition Tool before recreating the cloud provider, the cloud provider will not be visible. You must recreate it with a different name and re-import the images.
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Document Information
Modified date:
17 June 2018
UID
swg21669482