IBM Support

CCRC user login to CM Server fails with PAM and SSL setup for authentication: The server cannot be contacted

Troubleshooting


Problem

This technote identifies an issue that can occur where IBM Rational ClearCase Remote Client (CCRC) login attempts fail with the error, The server cannot be contacted. Please contact your system administrator, after setting up Secure Socket Layer (SSL) authentication on a Change Management (CM) Server.

Symptom

After attempting to setup the SSL authentication on the CM Server, no user is able to login in. The error the users see is:

The server cannot be contacted.  Please contact your system administrator.

If SSL is disabled, users are able to login.

In addition to the users being unable to login using CCRC, the ccrpc process that runs on the CM Server to process all the CCRC requests will crash or abort unexpectedly. There may be core files associated with the ccrpc process.

Cause


This issue has been identified as a product defect under APAR PM16947.

Resolving The Problem

The defect has been resolved in ClearCase 7.1.1.3.

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ClearCase Remote Client","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.1;7.1.0.1;7.1.0.2;7.1.1;7.1.1.1;7.1.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
19 February 2019

UID

swg21438341