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Causes of an LED 610 During a Sysback Network Boot

Question & Answer


Question

Causes of an LED 610 During a Sysback Network Boot

Answer

This document summarizes the causes and recovery procedures for an LED 610 during a Sysback network boot. The information in this document has been verified for AIX Versions 4 and later. It has also been verified for sysback.rte 4.2.x.x and later.

NOTE: Sysback versions 5.4.x and below are no longer supported.


Summary of the causes and recovery procedures

Condition:

An NFS mount of the /usr file system from the server is hanging during a Sysback classic network boot.

Possible causes:

  1. The /etc/exports file does not have the correct permissions for the client to mount /usr.

    Solution

    Execute the following command:

        exportfs
    

    Look for the line starting with /usr. Make sure the client host name is included on the line.

    Example

        /usr -ro, root=node1,node2
    

    In the preceding example, only node1 and node2 are exported to NFS mount /usr. If your client's host name is not included on that line, then add the network boot client using the smitty sysback command as follows:

        smitty sysback
    

    Choose the following options in sequence:

        Configuration Options
        Network Boot/Install Configuration
        Classic Network Boot
        Add or Change a Network Boot Client
    

    Make sure each entry is filled in correctly.

    Example

    Client network adapter type             [ethernet]
    Client platform/kernel type             [chrp/MP]
    Client hostname                         [mars.aix.dfw.ibm.com]
    Server IP address                       [9.19.129.186]
    Client gateway address (optional)       [9.19.141.241]
    Client subnet mask (optional)           [255.255.240.0]
    Client adapter hardware address (optional)    []
    

    NOTE: For NIM clients this information is defined when it is associated with the NIM SPOT under the following menu options:

        Configuration Options
        Network Boot/Install Configuration
        NIM Resource Boot Menu ->
        Add or Change a Network Boot Client
    

    The ethernet specific setting for NIM clients are defined in NIM, not Sysback.

    Execute the following command to verify the correct client host name:

        exportfs
    

    Look for the line starting with /usr. Make sure the client host name is included on the line.

  2. The /etc/exports file does not have an entry for /usr.

    Solution

    Execute the following command:

        exportfs
    

    If there is no entry for /usr in the /etc/exports file, then follow the steps in the solution in the preceding section.

    Watch for this error message when you are adding the network boot client (the example is for configuring a network boot for client thumper.aix.dfw.ibm.com):

        /usr ro,root=thumper.aix.dfw.ibm.com
        Starting NFS and BOOTP services ..
        exportfs: /usr: sub-directory (/usr/lpp) already exported
        /usr not found in /etc/exports
    

    If you get this error, the client has been configured but you must correct the problem with the export by performing the following steps, before booting the client.

    Execute the following command:

        exportfs
    

    If a subdirectory for /usr that is not a file system is already in the /etc/exports file, then you cannot export the parent directory /usr.

    Example output from the exportfs command

        /usr/sys/inst.images -rw
        /usr/lpp             -root=mars,access=mars
    

    In this example /usr/sys/inst.images is its own file system but /usr/lpp is still part of /usr file system. You cannot export /usr until you remove /usr/lpp from the /etc/exports file.

    To remove /usr/lpp from the /etc/exports file, execute the following command:

        /usr/sbin/rmnfsexp -d /usr/lpp  -B
    

    Then re-add the network boot client by following the steps for that process in the preceding section.

    Verify the addition by executing the following command:

        exportfs
    

    Look for the line starting with /usr. Make sure the client host name is included on the line.

    If you followed all of the preceding steps and the system still stops at an LED 610 during a network boot to Service mode, you may want to further pursue system recovery assistance from one of the following:

    • local branch office
    • your point of sale
    • your AIX support center


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Historical Number

isg1pTechnote0722

Document Information

Modified date:
17 June 2018

UID

isg3T1000414