IBM Support

Can't log into IMM GUI while doing firmware updates

Troubleshooting


Problem

While doing firmware update on Lenovo M5 IMM firmware using oem_fw_imm2_tcoe60a-5.90_anyos_noarch.uxz and getting message That IMM needs a restart.

Imm was restarted normally via command line using this command: /opt/ibm/toolscenter/asu/asu64 rebootimm

After the reboot, the IMM has been inaccessible and customer unable to get to the IMM login screen. 

Symptom

Unable to log into IMM GUI via browser.
Message that IMM needs a restart

Cause

During a firmware update, it's believed that the reason the IMM stage gets hung up is because we are flashing the IMM circuitry while IMM is running. This seems to cause IMM or one of the firmware packages to hang up the circuitry and make the IMM stage non responsive.

Environment

This particular environment is an M5 Lenovo appliance on QRadar 7.4.0 as of 10/3/2024.
The firmware update that was running is https://www.ibm.com/support/pages/node/6838609

Diagnosing The Problem

We had Teams meeting to diagnose the IMM GUI not responding issue after a firmware IMM update.

We found that the IMM IP, Subnet and Gateway IP's were reset to default 192.168.x.x IP numbers by the firmware update (unusual), so we corrected those to the correct IP's.

We verified that the customer used the correct M5 firmware update link with files and directions https://www.ibm.com/support/pages/node/6838609

We saw that all ports 80,443, 3900 and 5900 were closed with Windows Power Shell. Those will need to be opened, and were opened.

I also suggested a 5 minute power cord removal and boot after that and try the GUI we were working on.

Details of the power cord removal:

Do a normal shutdown of the OS via command line, or otherwise.

Once OS shut down, remove both power cords.

Start timing out 5 minutes on a watch or phone. Once past 5 minutes (less won't work. Guessing 5 minutes won't work) then re attach both power cords and boot appliance.

Allow appliance to completely boot 6 or 8 minutes.

Resolving The Problem

Do a normal shutdown of the OS via command line, or otherwise.

Once OS shut down, remove both power cords.

Start timing out 5 minutes on a watch or phone. Once past 5 minutes (less won't work. Guessing 5 minutes won't work) then re attach both power cords and boot appliance.

Allow appliance to completely boot 6 or 8 minutes.

Then attempt to open IMM GUI via browser and it should respond normally with login screen.

Document Location

Worldwide

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Document Information

Modified date:
14 October 2024

UID

ibm17172700