Troubleshooting
Problem
When running reports containing charts with a mobile device, the report does not appear in the device's inbox. Reports that do not contain charts appear in the inbox successfully. In the mob.log: [mobileThread-3] ERROR com.cognos.mobile.server.c8.request.C8RequestManager - The Mobile service has caught an exception: java.lang.InternalError: Can't connect to X11 window server using 'xx.xx.xx.xx:0.0' as the value of the DISPLAY variable.
Cause
The error occurs when Cognos Mobile is installed on UNIX based environments without graphics support. The Java 'Headless' operation option must be used to allow a Java program to run without a monitor, mouse or keyboard. Headless Java operation would mean that a server side Java program should be able to use the full J2SE or J2EE API without a GUI environment being present. This means that all AWT calls to manipulate components, graphics, fonts, printing etc. should be functional.
Environment
AIX, Solaris, HP-UX, Linux
Resolving The Problem
Specify the Java headless operation mode on the application server.
Steps
- Weblogic: Edit the startmanagedweblogic file for the Cognos server install and add -Djava.awt.headless=true to the JAVA_OPTIONS section.
- WebSphere: Edit the server-cfg.xml located in $WAS_ROOT/config. Add -Djava.awt.headless=true to the commandLineArguments="".
- Tomcat (Cognos default): Edit the bootstrap_<os_type>.xml located in ../c10/bin. Add Add <param>-Djava.awt.headless=true</param> above the entry <param>"-cp"</param>
**Note: The services/application servers need to be restarted for the changes to take effect.
Historical Number
1036711
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Document Information
Modified date:
15 June 2018
UID
swg21371384