Troubleshooting
Problem
Cannot login to the IBM Transformation Extender Advanced console after selecting the "Launch SPE Trading Partner UI" link from the Sterling B2B Integrator dashboard.
Symptom
Not able to login to the IBM Transformation Extender Advanced Trading Partner User Interface.
Cause
The Sterling B2B Integrator (B2Bi) REST Http Server Adapter is not enabled and running.
Diagnosing The Problem
When attempting to login to the IBM Transformation Extender Advanced (ITXA) console from the Sterling B2B Integrator (B2Bi) dashboard's Standards Processing Engine --> SPE Server --> "Launch SPE Trading Partner UI" option, the ITXA login screen is presented and after attempting to login, an error message is displayed stating "Please contact system administrator"
In a working environment the ITXA login screen should not be presented as the ITXA-B2Bi single sign on integration would login into ITXA automatically.
Resolving The Problem
- Login to the B2Bi dashboard
- Check the status of the REST Http Server Adapter by selecting Deployment --> Services --> Configuration and search for
REST Http Server Adapter
- In the Services Configuration screen, review the "Advanced Status" to ensure it's Enabled.
- If it is not enabled, select the Enabled check box to enable it.
- If it is enabled, click on the
REST Http Server Adapter
link and a pop-up window will appear displaying the REST Http Server Adapter. Ensure the System Audit Information states it is running.
Product Synonym
ITXA SPE Standards Processing Engine
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Document Information
Modified date:
15 May 2022
UID
swg22003644