IBM Support

Cannot log in to Network Advisor

Troubleshooting


Problem

You are suddenly unable to log in to the Network Advisor. Nothing has been changed on the server, and there has been no upgrade to the program, but the login is challenged and fails constantly. The server may be rebooted and it will still fail to provide access. Network Advisor displays a misleading error message.
 

Symptom

At the server login screen you are presented with this message:
image 3220
The error is tied to SQL in accessing the data during the login. The connection from the Network Advisor to the database was closed, and there is no other reference.

Cause

Network Advisor collects performance data from the SAN switches, and the problem is caused when the data has grown too large, which prevents the program to run properly due to insufficient storage available. The failure is not graceful and Network Advisor doesn't provide any clear insight about the cause.

Environment

Windows server or Linux server

Resolving The Problem

As long as admin access is available to the server you can go in to the file system and create some space.  After doing so you must reboot the server in order for Network Advisor to find the newly created space, and allow log in again.

Follow these Broadcom supplied directions below to clear up space:

Clearing Performance Data
To clear performance data (all time series child table data), run the following:
\Network Advisor 14.4.3\utilities\clear-performance-data.bat
On Windows systems, complete the following steps:
     a. Open a command prompt and navigate to the Install_Home\utilities directory.
     b. Clear performance data by typing clear-performance-data.bat dbusername dbpassword and pressing Enter.
For example: clear-performance-data.bat dcmadmin passw0rd

Document Location

Worldwide

[{"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"STMSDB","label":"Storage area network (SAN)->IBM Network Advisor"},"ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"","label":""}}]

Product Synonym

BNA; INA; Network Advisor

Document Information

Modified date:
05 May 2020

UID

ibm16205929