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Cannot create Distributed File System (DFS) links from FileNet Enterprise Manager (FEM).

Troubleshooting


Problem

When creating a DFS link to point to the File System using FEM, it generates an Access Denied error.

Symptom

Access Denied, Error Code: 80004005

Cause

The user permission of the Websphere (WAS) services running as a Windows Service was not set properly. For example, the user running the WAS process should be a domain account or one that can access the DFS/storage area. A service user logging on as a "Local System" user will have NO network resources available.

Diagnosing The Problem

  1. Enable P8 Tracing

  2. The P8 Trace logs will have the following errors


    at com.ibm.websphere.security.auth.WSSubject.doAs(WSSubject.java:194)
    at com.ibm.websphere.security.auth.WSSubject.doAs(WSSubject.java:151)

  3. If using WAS as a Windows Services, verify that the service user was set to "Local System".

  4. Change the user from "Local System" to a dedicated domain user who has privileges on the DFS.

Resolving The Problem

The service user was set to the Local System user. After changing it to the appropriate domain user who has access to the DFS server, users were able to create their initial object store with the DFS link.

[{"Product":{"code":"SSNVNV","label":"FileNet Content Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Content Engine","Platform":[{"code":"PF033","label":"Windows"}],"Version":"5.1.0;5.2.0","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21598624