Troubleshooting
Problem
Attempts to copy the agentData folder on Microsoft Windows fails because some of the folders in agentData folder have a long file name.
Symptom
- Go to C:\Documents and Settings\All Users\Application Data\IBM\
- Copy Installation Manager
- Paste the folder to the same directory or a different directory
Windows displays an Error dialog:
Cannot copy file:
Cause
This issue is related to the file name path limitations on Windows.
Review the article in the Related information section below for more details.
Resolving The Problem
WORKAROUNDS:
For IBM Installation Manager 1.3:
- Launch IBM Installation Manager 1.3
- Click Help > Export Data for Problem Analysis
- Click Browse and Select a directory that you would like to use
- Provide a name for the file, click Save > OK
To perform the same steps in silent mode, please use the instruction that is provided at
http://publib.boulder.ibm.com/infocenter/install/v1r2/index.jsp?topic=/com.ibm.silentinstall12.doc/topics/t_silent_dataexport.html.
For IBM Installation Manager 1.2.x's users who cannot upgrade to version 1.3:
- Download IBM Installation Manager version 1.3
- Extract the contents to a temp folder
- Make a backup copy of silent-install.ini
- Open the copied version of silent-install.ini and remove -input and @... lines
- Run <path>installc.exe --launcher.ini <path>\<copied silent-install.ini> -exportInstallData <path>\<filename>.zip
Related Information
[{"Product":{"code":"SSDV2W","label":"IBM Installation Manager"},"Business Unit":{"code":null,"label":null},"Component":"General information","Platform":[{"code":"PF033","label":"Windows"}],"Version":"1.2;1.2.1;1.3","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21381534