Question & Answer
Question
Cannot add items to shopping cart due to insufficient inventory errors when using the buy online, pickup in-store feature *|* -BF361DBD18A19617852576AF000FAD6D- *|*
Answer
Technote (troubleshooting)
Problem(Abstract)
While using the buy online pickup in-store feature customers cannot add items to their shopping cart when the online store contains insufficient inventory for order items even though the store location contains sufficient inventory to pickup.
Symptom
When a customer tries to add a product to their shopping cart an error message displays to indicate that there is insufficient inventory in the online store to fulfill the order.
Cause
When a customer tries to add an item to their shopping cart while using the buy online pickup in-store feature in a starter store such as the Madisons starter store the store assumes that the product is delivered to the customer using the default shipping mode defined for that store. Typically the default shipping mode is set to use a method such as express delivery not to pickup the order item in-store.
After the shipping mode is determined WebSphere Commerce finds a supported fulfillment center for the store using information contained in the SHPARRANGE database table.
Since the fulfillment centers related to the store locations only support the PickupInStore shipping mode the starter store cannot use these fulfillment centers for the online shopping flow even if there is sufficient inventory to fulfill an order.
Resolving the problem
If the store locations can support other shipping modes you can update the SHPARRANGE database table with the following SQL statement to enable the store locations to support online shopping:
UPDATE SHPARRANGE SET SHIPMODE_ID=null WHERE STORE_ID=$STORE_ID AND SHIPMODE_ID IN (SELECT SHIPMODE_ID FROM SHIPMODE WHERE CODE=PickupInStore AND STOREENT_ID=$STORE_ID);
Where $STORE_ID is the store identifier number of your store such as 10101. When SHIPMODE_ID is set to null the fulfillment centers can be used for all shipping modes that are supported in the store.
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Document Information
Modified date:
13 October 2021
UID
ibm10771201