Troubleshooting
Problem
A best practice for using the Secure Cloud Connector (SCC) feature is to restrict the number of Secure Cloud Connectors on the DataPower appliance to 32 or fewer.
Symptom
If running with a large number of Secure Cloud Connectors (cloud instances), an internal resource problem might prevent one or more of the connectors from coming up. The error log will contain a message similar to the following:
Feb 10 07:02:05 109958-729753 [system][error] trans(1): DataPower SecureCloudConnector task is not responding, restart in progress.
There might also be a backtrace in the temporary directory.
Cause
A resource contention problem with Secure Cloud Connectors only might cause the outage if more than 32 connectors are configured.
Environment
The Secure Cloud Connector capability is present when the Option for Application Optimization (AO) feature is installed.
Diagnosing The Problem
You are running firmware version 4.0.1 or later on an appliance with the Option for Application Optimization (AO) feature installed, and you see the following symptoms:
- The Secure Cloud Connector intermittently connects to the host in the cloud.
- The "SecureCloudConnector task is not responding" error message and backtrace
This could be the problem.
Resolving The Problem
The Secure Cloud Connector feature uses a keep alive mechanism to ensure the health of the secure cloud connector. When many SCC instances are configured, this mechanism might not respond quickly enough to consider the instance healthy. The result is that the SCC instance gets moved to the 'down' state and does not come back on line.
If you see this occur, you might circumvent it by configuring fewer Secure Cloud Connector instances.
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Document Information
Modified date:
15 June 2018
UID
swg21585446