IBM Support

Barcode Scanning but not Registering

Troubleshooting


Problem

You might be unable to scan bar code 39 and code 128.

Cause

The device might be sending information too fast for Maximo Mobile to handle.

Environment

Maximo Mobile 7.5.1

Resolving The Problem

STEPS:

1. Disable the symbol library in the mobile.properties file.

// Barcode settings
// possible values for maximo.mobile.barcode property are
// SYMBOL - Enables barcoding for Symbol Devices
// INTERMEC - Enables barcoding for Intermec Devices
// PANASONIC - Enables barcoding for Panasonic Toughbook Devices
// CUSTOM - Enables customized barcoding for device not supported out of box
// Please note that code changes are needed for this.
//maximo.mobile.barcode=SYMBOL

Then re-package and and redeploy the mobile jar files.

2. Enable Data Wedge on the device.



3. Change the InterChar delay from a default of 0 to 100 ms because the device might be sending information too fast for Maximo Mobile to handle.



It should scan both Code 39 and Code 128 barcodes into the itemnum field now.





[{"Product":{"code":"SSLL3Y","label":"Maximo Mobile Inventory Manager"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Mobile Inv Mgr","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
14 November 2019

UID

swg21966794