IBM Support

Backup operation for an IBM Spectrum Protect database takes a long time to complete

Troubleshooting


Problem

The database backup process runs successfully, but takes a long time to complete.

Cause

The cause is poor performance of the Transmission Control Protocol (TCP) loopback.


Tip: The product now known as IBM Spectrum Protect™ was named IBM Tivoli® Storage Manager in releases earlier than Version 7.1.3. To learn more about the rebranding transition, see technote 1963634.

Diagnosing The Problem

Examine the tsmdbmgr.opt file that is used by the server instance. In this case, the database backup operation was configured to use the TCP/IP protocol with the loopback address.

Resolving The Problem

To resolve the issue, take one of the following actions:

  • Configure the server instance to use the shared memory protocol for the database backup process instead of TCP/IP.
  • Consider increasing the number of parallel data movement streams to use for database backup operations. You can increase the number of streams by setting the NUMSTREAMS parameter on the BACKUP DB command. For more information, see BACKUP DB.

[{"Product":{"code":"SSEQVQ","label":"IBM Spectrum Protect"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

tsm

Document Information

Modified date:
17 June 2018

UID

swg22006701