Troubleshooting
Problem
Attempt to backup a VM with the command line Tivoli Storage Manager Client (dsmc) may generate an ANS1111W message because Changed Block Tracking (CBT) is not enabled.
Symptom
Attempts to backup a VM with the Tivoli Storage Manager command line client (dsmc) will result in output similar to the following:
C:\Program Files\Tivoli\TSM\baclient>dsmc backup vm
IBM Tivoli Storage Manager
Command Line Backup-Archive Client Interface
Client Version 6, Release 2, Level 3.0
Client date/time: 07/06/2011 10:17:35
(c) Copyright by IBM Corporation and other(s) 1990, 2011. All Rights Reserved.
Node Name: PROXYNODE
Session established with server TESTSRV: AIX
Server Version 6, Release 2, Level 2.34
Server date/time: 07/06/2011 10:24:33 Last access: 07/06/2011 10:22:10
Backup VM command started. Total number of virtual machines to process: 1
Backup of Virtual Machine 'TESTVM' started
ANS9365E VMware vStorage API error.
TSM function name : visdkPrintSOAPError
TSM file : vmvisdk.cpp (926)
API return code : 12
API error message : SOAP 1.1 fault: "":ServerFaultCode[no subcode]
"Permission to perform this operation was denied."
Detail:
Starting Full VM backup of Virtual Machine 'TESTVM'
Incremental backup of Virtual Machine 'TESTVM'
Backing up Full VM configuration information for 'TESTVM'
5,034 VM Configuration [Sent]
ANS1111W: Incremental backup unsuccessful for virtual machine 'TESTVM'. Performing Full backup instead.
Backing up Full VM configuration information for 'TESTVM'
5,034 VM Configuration [Sent]
ANS1111W: Unable to get VMware Changed Block Tracking(CBT) data for VM TESTVM; Full VM backup will continue, and include both used and unused areas of the disk.
Processing snapshot disk [DS5020-RAID-5] TESTVM/TESTVM.vmdk
(Hard Disk 1), Capacity: 48,318,382,080, Bytes to Send: 48,318,382,080 (nbd)[s
nding]
< 3.00 GB> [ - ]
<output truncated..>
If the backup is performed via the GUI, the ANS1111W message will be generated in the dsmerror.log instead.
Cause
The vStorage API error and the ANS1111W message are a result of Changed Block Tracking (CBT) being disabled for the VM that is being backed up. Changed Block Tracking allows Tivoli Storage Manager to back up only used portions of a VMDK file.
Diagnosing The Problem
Verify if Changed Block Tracking is enabled by right clicking on the VM in the vSphere client and going to 'edit settings'. Select the options menu, followed by click on 'General' and then 'Configuration Parameters":
Next, check and see if an option for 'ctkEnabled' exists and if it is set to true:
Resolving The Problem
If the ctkEnabled option is not present or set to false then it means that the ESX or ESXi host will not allow a backup to utilize the Changed Block Tracking technology.
VMware has the following guide with detailed instructions on how to enable Changed Block Tracking:
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1020128
Once Changed Block Tracking (CBT) has been enabled using the VMware guide, attempt the backup of the VM again and the error messages should no longer be generated.
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Document Information
Modified date:
17 June 2018
UID
swg21579399