IBM Support

AZURE VM Backup Failure

Troubleshooting


Problem

AZURE VM Backup fails due to inability to communicate with the VM agent


Symptom

AZURE VM Backup fails with the following:

Could not communicate with the VM agent for snapshot status - Snapshot VM sub task timed out

"Sev: Critical | Alert: Backup Failure | Backip Items: “Server Name” | Description: Could not communicate with the VM agent for snapshot status | Recommended Action(s): Please retry the backup operation. If the issue repeats, follow the instructions at: http://go.microsoft.com/fwlink/?LinkId=800034 | Time: October 10, 2024 12:07 UTC | Vault: “Vault Name"


Cause

Corruption or missing VM Agent on VM

Environment

AZURE VM

Diagnosing The Problem

First make sure the issue is not addressed in the following document below: 

Troubleshoot Azure Backup failures caused by agent or extension issues

https://learn.microsoft.com/en-us/azure/backup/backup-azure-troubleshoot-vm-backup-fails-snapshot-timeout

Next if the above article does not apply, please proceed with the following:

Check the following and compare to a VM where backups are succeeding.

C:\Packages\Plugins\Microsoft.Azure.RecoveryServices.VMSnapshot found that required metadata and other files were removed.

Checking the following registry keys and values to see if they are not set to false

  • REG ADD "HKLM\SOFTWARE\Microsoft\BcdrAgent IsProviderInstalled
  • HKLM\SOFTWARE\Microsoft\BcdrAgentPersistentKeys IsCommonProviderInstalled

Resolving The Problem

If contents appear incorrect or missing in C:\Packages\Plugins\Microsoft.Azure.RecoveryServices.VMSnapshot

  • Rename the Folder "Microsoft.Azure.RecoveryServices.VMSnapshot"
  • Copy the "Microsoft.Azure.RecoveryServices.VMSnapshot" folder from a working VM
Note: If the contents Microsoft.Azure.RecoveryServices.VMSnapshot appear fine, you may simply proceed to the next section without the need to copy.

Note: Always consider backup the registry key before making changes

Next Run registry key command one by one from an elevated CMD prompt

  • REG ADD "HKLM\SOFTWARE\Microsoft\BcdrAgent" /v IsProviderInstalled /t REG_SZ /d False /f
  • REG ADD "HKLM\SOFTWARE\Microsoft\BcdrAgentPersistentKeys" /v IsCommonProviderInstalled /t REG_SZ /d False /f
Once the values are set to false, then perform the following:

  • Restart Windows Azure guest agent service
  • Trigger Backup in Azure Portal (Open VM --> Backup --> Backup Now)

Document Location

Worldwide


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Document Information

More support for:
Microsoft Azure

Component:
AZURE

Document number:
7239567

Modified date:
15 July 2025

UID

ibm17239567

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