IBM Support

Audit library command hanging

Troubleshooting


Problem

Audit library command is executed to refresh/update the library inventory for a Tivoli Storage Manager but the command appears to hang for a period of time.

Cause

Volumes mounted in the drives.

Resolving The Problem

To avoid any contention with the Audit Library command, run the Audit Library command when the following conditions are met :

  • Library is Idle.
  • No volumes are mounted in the drives.
  • At least one drive is available, in case a volume needs to be mounted to read the internal label when a barcode is unreadable.

Note that the AUDIT LIBRARY command does not automatically add new volumes to a library. To add new volumes, you must use the CHECKIN LIBVOLUME command.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21667779