Troubleshooting
Problem
Audio/Video feed from a USB microphone or USB camera connected to a View Client can be choppy or jittery. This is a result of the use of the USB redirection channel for real-time functions such as audio or video.
Symptom
A video image may jerk back and forth, or seem to have a very low frame rate. The audio may sound like a bad connection.
Cause
This results because the USB redirection uses several back and forth communications and acknowledgements for each piece of the audio/video data stream. This is an ineffective way to transmit audio/video data and is NOT a supported method.
Environment
VMware View® client with USB devices, connecting to View desktop VM
Resolving The Problem
In order to correct this, the user must be using View 5.3, and a View Client which can accept the Real Time Audio Video (RTAV) portion of the View 5.3 Feature Pack. This means it cannot be implemented with a zero client, and may only be compatible with some thin clients.
https://www.vmware.com/pdf/horizon-view/horizon-view-53-feature-pack-document.pdf
Additionally, when connecting the View Client to the desktop VM, you must ensure that the microphone/camera is NOT connected via USB redirection. If it is not, then the RTAV component of the feature pack should establish the connection for those items to the target. Additional configuration instructions are available in the PDF document.
RTAV client side components are included in View Client 2.2 and beyond. The RTAV components must also be installed within the desktop VM.
There is also a Fling application from VMware® that can be used to "test" the audio/video capabilities of the device at the client end, and again at the desktop VM end of the connection.
https://labs.vmware.com/flings/real-time-audio-video-test-application
https://www.vmware.com/pdf/horizon-view/horizon-view-53-feature-pack-document.pdf
Additionally, when connecting the View Client to the desktop VM, you must ensure that the microphone/camera is NOT connected via USB redirection. If it is not, then the RTAV component of the feature pack should establish the connection for those items to the target. Additional configuration instructions are available in the PDF document.
RTAV client side components are included in View Client 2.2 and beyond. The RTAV components must also be installed within the desktop VM.
There is also a Fling application from VMware® that can be used to "test" the audio/video capabilities of the device at the client end, and again at the desktop VM end of the connection.
https://labs.vmware.com/flings/real-time-audio-video-test-application
Related Information
[{"Product":{"code":"SSCLB3","label":"VMware Solutions"},"Business Unit":{"code":"BU053","label":"Cloud \u0026 Data Platform"},"Component":"View","Platform":[{"code":"","label":"VMWare"}],"Version":"5.3","Edition":"","Line of Business":{"code":"LOB66","label":"Technology Lifecycle Services"}}]
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Document Information
Modified date:
27 February 2020
UID
isg3T1020757