IBM Support

Attempting to send an entity to Google Earth in IBM i2 Analyst's Notebook results in a 'failed to initialize' error.

Troubleshooting


Problem

When sending an entity from Analyst's Notebook (ANB) to Google Earth, the following error appears and Google Earth does not start: 'Google Earth failed to initialize. Please check that Google Earth version 4.2 or higher is installed, it is configured correctly and that your connection to the Google Earth server is working.'

Symptom

Cause

This error can occur if the Google installer does not register the Google Earth (GE) executable as a COM component - for GE versions prior to December 12th, 2015. This technote may resolve the issue reported if using Analysts notebook (any version) with GE versions released BEFORE December 12th, 2015
Please note Google deprecated the Earth API in Google Earth versions released after December 12th, 2015. As a result, Analysts notebook may not chart to Google Earth versions released after December 12th, 2015.
The above error and the error reported in http://www.ibm.com/support/docview.wss?uid=swg21990583
are a consequence of using Analysts notebook (any version) with Google Earth versions released after December 12th, 2015 that were not compatible or not registered correctly. (See note below)
Below are the Google earth versions tested, known to be compatible/not compatible with ANB:

GE v 6.2.2.6613 - [COMPATIBLE - Ends & Links are sent & drawn on the GE Map]

GE v7.1.8.3036 - [COMPATIBLE - Ends & Links are sent & drawn on the GE Map]

Google Earth Pro

v 6.2.2.6613 - [COMPATIBLE - Ends & Links are sent & drawn on the GE Map]
v 7.1.8.3036 - [COMPATIBLE - Ends & Links are sent & drawn on the GE Map]

v 7.3.1 (32-bit) - [COMPATIBLE - Ends & Links are sent & drawn on the GE Map]
v 7.3.1 (64-bit) - [NOT COMPATIBLE]


NOTES:
When you search for Google Earth download, the default drop page offers the download of v7.3.1 (64-bit) which does not work with ANB. To get a compatible version, you have to navigate to the "Direct Installers page" (found here: https://support.google.com/earth/answer/168344?hl=en).

For all the compatible versions, you have to manually register the Google Earth executable:

- go to GE's install folder using the Command Prompt
- run/execute the following "GoogleEarth.exe /regserver"

If a later compatible version of Google Earth is not available then as an alternative, instead use the Map chart items to Esri feature introduced in Analysts notebook 9.0.5 or later
https://www-01.ibm.com/support/docview.wss?uid=swg27036288

Resolving The Problem

There are three workarounds for this problem.

Option 1: Manually register the Google Earth executable.


    1. Open a Command Prompt window - ensure you run it as Administrator.

    2. Navigate to the installation directory for Google Earth (by default C:\Program Files (x86)\Google\Google Earth\client)



    3. Run the following command: googleearth.exe /regserver

Option 2: Start Google Earth manually, before attempting to send an entity to it from Analyst's Notebook.

Option 3: In some rare cases, you may get this error without trying to send an entity to Google Earth. If you enabled the Google Earth plug-in previously, but no longer wish to use it, an alternative is to simply disable the Google Earth plug in.

To disable the Google Earth plug-in, navigate to Settings-->Customize-->Plug-ins-->i2 Google Earth Plug-in, as shown below.  Uncheck the "Load on Startup" box. Then restart Analyst's Notebook. 


[{"Product":{"code":"SSXUXD","label":"i2 Analyst's Notebook"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.0.0;9.0.1;9.0.2;9.0.3","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

More support for:
i2 Analyst's Notebook

Software version:
9.0.0, 9.0.1, 9.0.2, 9.0.3

Operating system(s):
Windows

Document number:
711069

Modified date:
21 June 2018

UID

swg21989189