IBM Support

Attempting to run IBM i2 Analyst's Notebook setup from within a compressed folder causes an error

Troubleshooting


Problem

Attempts to install IBM i2 Analysts's Notebook from within the downloaded compressed folder results in the error "No explicit configuration file was specified and no default was found."

Symptom

Launching the "setup.exe" application from within the IBM i2 Analyst's Notebook compressed folder causes the error "No explicit configuration file was specified and no default was found."

Cause

This error occurs due to the "setup.exe" application being unable to write or read specific files also contained within the compressed folder. A compressed folder, also known as a ZIP file, must first be extracted prior to the application being run.

Environment

Windows
Any downloaded ZIP file - specifically those downloaded from the IBM Passport Advantage product website.

Diagnosing The Problem

In order to determine if this situation applies, look at the following screen shot to compare to your desktop environment:

After downloading the file, you immediately double-click on it and are taken into what seems like a normal folder. However, there are subtle differences that can assist with determining if this is a compressed (ZIP) folder.




1. At the top of the window, in the location bar, the folder icon to the left of the path name will appear to have a small zipper down the center.

2. The path name may include the file extension of .zip

3. The application icon shows a generic icon appearing as a small, blue box inside a tiny "window"

Resolving The Problem

To resolve this error, you must first extract the compressed (ZIP) file contents to a normal folder. This can be done by performing the following:

1. Locate the compressed file by navigating to the save location that the file was downloaded or saved to.

In this example, the folder "Product Installs" is located on the Desktop. Please note the difference between a normal folder icon (upper left red box) and a compressed folder (lower right red box)

2. Right click on the file that needs to be decompressed or "unzipped".


*Note* As you can see, another compression utility named "7-Zip" is installed. For this procedure, we will use the operating systems built-in compression utility. Please consult 3rd party documentation for a similar procedure using other common compression utilities.

3. Choose the "Extract All..." option after right clicking the desired file.

4. On the resulting window, select the checkbox labeled "Show extracted files when complete"

5. Verify that the folder location is the desired destination. If not, click "Browse" to choose a new location.
*Note* Ensure that you have Write privileges on the folder you select, or an error will be received.

6. Click "Extract", shown in the above screen shot. A short operation will commence to extract the files into the destination folder. You may see a status bar while the operation is performed.

Once the operation completes, the extracted contents will now be displayed in a new window

7. Verify that the folder is now the uncompressed version:

1. The folder in the location bar no longer has a small zipper in the center

2. The path name does not end with .zip

3. The setup.exe icon now appears as a small CD with a green downward pointing arrow

The contents of the compressed (ZIP) folder are now extracted properly and the installation of the software can now begin from the new, uncompressed folder.

[{"Product":{"code":"SSXUXD","label":"i2 Analyst's Notebook"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.9.7;8.9.5;8.9.3;8.9.1;8.9;8.7;8.5;8.0;7.0;6.0;8.9.9;8.9.11","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21958052